Premium phone support may be temporarily unavailable.
Incident Report for Penneo A/S
Resolved
Premium phone support is available.
Posted Sep 05, 2024 - 10:06 CEST
Identified
Our premium phone support may be temporarily unavailable as we change providers.

You can contact Penneo Technical Support via the form below:

https://penneo.my.site.com/support/s/contactsupport?language=en_US
Posted Sep 05, 2024 - 08:10 CEST
This incident affected: Penneo Support.